Technolec

NPORT 6400-G2 SERIES

2nd Gen 4-port RS-232/422/485 secure terminal server, -10 to 60°C operating temperature
nport-6400-g2-series
Data encryption with secure operation modes for Real COM, TCP Server, TCP Client, Pair Connection, Terminal, and Reverse Terminal
Secure Boot only allows Moxa-authorized firmware to run on devices
One-click log collection and application analysis for easy troubleshooting
Easy RS-485 configuration of serial interfaces with software-adjustable pull high/low resistor and terminator
Supports SSL certificate signing by RSA-4096 / ECC-521
IEC 62443-4-2 Security Level 2 certified

Memory

  • SD Slot: microSD cardUp to 2 TB (high speed, 25 Mbps)

Ethernet Interface

  • 10/100BaseT(X) Ports (RJ45 connector): 1
  • Magnetic Isolation Protection: 1.5 kV (built-in)

Ethernet Software Features

  • Configuration Options: Web Console (HTTP/HTTPS) Windows Utility Device Search Utility (DSU) MCC Tool Serial Console
  • Management: ARP, DHCP Client, DNS, HTTPS, ICMP, IPv4/IPv6, SMTP, SMTPS, SNMPv1/v2c/v3, SNTP, TCP/IP, UDP, WINS
  • Windows Real COM Drivers: Windows 11, 10, 8.1, 8, and 7Windows Server 2022, 2019, 2016, 2012 R2, 2012, and 2008 R2
  • Linux Real TTY Drivers: Kernel versions 6.x, 5.x, and 4.x
  • Fixed TTY Drivers: macOS versions: 14, 13, 12, and 11
  • Arm®-based Platform Support: Windows 11Linux kernel 6.x, 5.x, and 4.xmacOS 14, 13, 12, and 11
  • Virtual Machine: VMWare ESXi (Windows 11/10/8.1/8/7 & Linux 6.x, 5.x, and 4.x)VMware Fusion (Windows on macOS 14, 13, 12, and 11)Parallels Desktop (Windows on macOS 14, 13, 12, and 11)
  • Time Management: SNTP Client
  • MIB: MIB-II RFC1213, RFC1317 Private MIB
  • Unicast Routing: RIPV1/V2 Static Route

Security Functions

  • Root of Trust: Secure Boot True Random Number Generator (TRNG)
  • Authentication: Local database RADIUS TACACS+
  • Security Protocols: HTTPS (TLS 1.2/1.3) SNMPv3 SSHv2
  • Encryption: HTTPS: ECC-256, ECC-384, ECC-521, RSA-1024, RSA-2048, RSA-3072, RSA-4096, AES-128, AES-256, CHACHA20, SHA-256, SHA-384, HMACSSH: ECC-256, ECC-384, ECC-521, RSA-2048, AES-128, AES-256, SHA-256, SHA-384, HMACSNMPv3: AES-128, SHA-256, SHA-384Secure OP mode: HTTPS: ECC-256, ECC-384, ECC-521, RSA-1024, RSA-2048, RSA-3072, RSA-4096, AES-128, AES-256, CHACHA20, SHA-256, SHA-384, HMACConfig Import/Export: AES-256, SHA-256, HMAC

Serial Interface

  • No. of Ports: 4
  • Connector: DB9 male
  • Serial Standards: RS-232 RS-422 RS-485
  • Secure Operation Modes: Secure Real COM, Secure TCP Server, Secure TCP Client, Reverse SSH, SSH, Secure Pair Connection, Secure Redundant COM, Secure Reverse Real COM
  • Standard Operation Modes: Real COM, RFC2217, TCP Server, TCP Client, Reverse Terminal, Terminal, UDP, Pair Connection, PPP, SLIP, Redundant COM, Reverse Real COM, Disable
  • Baudrate: 50 bps to 921.6 kbps (supports non-standard baudrates)
  • Data Bits: 5, 6, 7, 8
  • Stop Bits: 1, 1.5, 2
  • Flow Control: None RTS/CTS DTR/DSR RTS Toggle XON/XOFF
  • Parity: None, Even, Odd, Space, Mark
  • RS-485 Data Direction Control: Automatic Data Direction Control (ADDC)
  • Terminator for RS-485: 120 ohms (software–configurable)
  • Pull High/Low Resistor for RS-485: 1 kilo-ohm, 150 kilo-ohms (software–configurable)

Serial Signals

  • RS-232: TxD, RxD, RTS, CTS, DTR, DSR, DCD, GND
  • RS-422: Tx+, Tx-, Rx+, Rx-, GND
  • RS-485-4w: Tx+, Tx-, Rx+, Rx-, GND
  • RS-485-2w: Data+, Data-, GND

Power Parameters

  • Input Current: 373 mA (max.)
  • Input Voltage: 12 to 48 VDC

Reliability

  • Automatic Reboot Trigger: Built-in WDT
  • Alert Tools: Built-in buzzer and RTC (real-time clock)

Physical Characteristics

  • Housing: Metal
  • Dimensions (with ears): 182 x 114.4 x 30 mm (7.17 x 4.50 x 1.18 in)
  • Weight: 538 g (1.186 lb)
  • Weight (including package): 900 g (1.984 lb)
  • Installation: Desktop DIN-rail mounting (with optional kit) Wall mounting
  • Dimensions (without ears): 158 x 114.4 x 30 mm (6.22 x 4.50 x 1.18 in)

Environmental Limits

  • Operating Temperature: -10 to 60°C (14 to 140°F) With power adapter (included in the package): 0 to 40°C (32 to 104°F)
  • Storage Temperature (package included): -40 to 75°C (-40 to 167°F)
  • Ambient Relative Humidity: 5 to 95% (non-condensing)

Standards and Certifications

  • EMC: EN 55032/35
  • EMI: CISPR 32, FCC Part 15B Class A
  • EMS: IEC 61000-4-2 ESD: Contact: 4 kV; Air: 8 kV IEC 61000-4-3 RS: 80 MHz to 1 GHz: 3 V/m IEC 61000-4-4 EFT: Power: 1 kV; Signal: 0.5 kV IEC 61000-4-5 Surge: Power: 1 kV IEC 61000-4-6 CS: 3 V IEC 61000-4-8 PFMF IEC 61000-4-11
  • Safety: IEC 62368-1 UL 62368-1 EN 62368-1
  • Traffic Control: NEMA TS2
  • Vibration: IEC 60068-2-6
  • Package Drop Test: ISTA 1A
  • Cybersecurity: IEC 62443-4-2 Security Level 2

Declaration

  • Green Product: RoHS, CRoHS, WEEE

MTBF

  • Time: 29,716 hrs
  • Standards: Telcordia Standard SR-332 Telcordia SR-332 Standard Issue 4

Warranty

  • Warranty Period: 5 years
  • Details: See www.moxa.com/warranty

Available Models

Model No. Description Quantity
NPort 6450-G2 2nd Gen 4-port RS-232/422/485 secure terminal server, -10 to 60°C operating temperature
NPort 6450-G2-T 2nd Gen 4-port RS-232/422/485 secure terminal server, -40 to 75°C operating temperature
NPort 6450-2TX-G2 2nd Gen 4-port RS-232/422/485 secure terminal server with 2 RJ45 100M LAN ports, -10 to 60°C operating temperature
NPort 6450-2TX-G2-T 2nd Gen 4-port RS-232/422/485 secure terminal server with 2 RJ45 100M LAN ports, -40 to 75°C operating temperature
NPort 6450-2M-SC-G2-T 2nd Gen 4-port RS-232/422/485 secure terminal server with 2 multi-mode SC 100M LAN ports, -40 to 75°C operating temperature
NPort 6450-2S-SC-G2-T 2nd Gen 4-port RS-232/422/485 secure terminal server with 2 single-mode SC 100M LAN ports, -40 to 75°C operating temperature